e-quinux

VPN Configuration Guide

D-Link DFL-200

Revision 1.0.0



equinux AG and equinux USA, Inc.
© 2007 equinux USA, Inc. All rights reserved.

Under the copyright laws, this manual may not be copied, in whole or in part, without
the written consent of equinux AG or equinux USA, Inc. Your rights to the software are
governed by the accompanying software license agreement.

The equinux logo is a trademark of equinux AG and equinux USA, Inc,, registered in the
U.S. and other countries.

Every effort has been made to ensure that the information in this manual is accurate.
equinux is not responsible for printing or clerical errors.

Created using Apple Pages.

www.equinux.com

Apple, the Apple logo, iBook, Mac, Mac OS, MacBook, PowerBook are trademarks of
Apple Computer, Inc,, registered in the U.S. and other countries.

Finder and Mail are trademarks of Apple Computer, Inc. AppleCare is a service mark of
Apple Computer, Inc,, registered in the U.S. and other countries.

FileMaker is a trademark of FileMaker, Inc.

equinux shall have absolutely no liability for any direct or indirect, special or other
consequential damages in connection with the use of the quick setup guide or any
change to the router generally, including without limitation, any lost profits, business,
or data, even if equinux has been advised of the possibility of such damages.


http://www.equinux.com
http://www.equinux.com

[T 0 o Ye [0 [et (0] o FUUE R 5

Prer@QUISItES.....ceeieerescncsesnsesssssnsansesesssnsssssasnssssssasesess 6
(= g T 1 Lo I 7
Task 1 - Configure your D-Link DFL-200................... 9
Step 1 - Add a New VPN Tunnel 10
Step 2 - Configure your VPN Tunnel 1
Step 3 - Activate the VPN Tunnel 13
Step 4 - Add a New VPN User. 14
Step 5 - Activate the User 16

Task 2 — Configure VPN Tracker..........ceceeeevereerererenens 17

Step 1 - Create a new Connection 17
Step 3 - Network Settings 19
Step 4 - Authentication Settings. 20
Step 5 - Identifiers Settings 21

Task 3 - Check the VPN connection.........ccoeeeeennes 22

It's time to go out! 22
Test your connection 22
Troubleshooting.........ccceeeeeeenenerereeennnnesesesesesesenesennns 25
WHhat's NEXTY....ccerrrrrrerieccensnnnsasnsnsnssesessssssssasasnnss 26
Introduction 26
Known Limitations 26
Accessing Files 27

Accessing a FileMaker Database 29

Acquire more Licenses






Introduction

This document describes how VPN Tracker can be used to establish a connection between a Macintosh running Mac OS X
and a D-Link DFL-200 router.

The D-Link gateway is configured as a router connecting a company LAN to the Internet.

This paper is only a supplement to, not a replacement for, the instructions that have been included with your D-Link
DFL-200. Please be sure to read those instructions and understand them before starting.

EQUINUX SHALL HAVE ABSOLUTELY NO LIABILITY FOR ANY DIRECT OR INDIRECT, SPECIAL OR OTHER CONSEQUENTIAL
DAMAGES IN CONNECTION WITH THE USE OF THE HOW-TO OR ANY CHANGE TO THE ROUTER GENERALLY, INCLUDING
WITHOUT LIMITATION, ANY LOST PROFITS, BUSINESS, OR DATA, EVEN IF EQUINUX HAS BEEN ADVISED OF THE POSSIBILITY
OF SUCH DAMAGES.



Prerequisites

First you have to make sure to use a recent D-Link DFL-200 firmware version. The latest release for your D-Link firewall can
be obtained from http://www.d-link.com/

For this document, firmware version 1.34.00 has been used.
Please note: VPN Tracker has been only been tested with the D-Link DFL-200 and the above firmware version.
You will need one VPN Tracker Personal Edition license for each Mac connecting to the DFL-200.

We recommend one VPN Tracker Professional Edition for the administrator’s Mac in order to export configuration files to
the clients. VPN Tracker is compatible with Mac OS X version 10.2.5+, 10.3 and 10.4.1+


http://www.linksys.com
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Scenario

In our example, we need to connect an employee's Mac Book in San Francisco to an office in New York. The following
diagram illustrates this scenario:

—

The MacBook is directly connected to the Internet and has a public IP address, assigned by an ISP.

The office's VPN gateway is also connected to the Internet and can be accessed via an static IP address. The VPN gateway

also has a second interface which is connected to the internal office network. In our example, the office network has the
IP range 192.168.13.0/24.

A VPN tunnel will be established between the public interfaces in San Francisco and New York. Once the VPN tunnel is up,
San Francisco can access the office network behind the VPN gateway.
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Please note that the connection from a MacBook at home to an office network is just one possible scenario. The
instructions also apply to connections from a desktop computer or notebook in your office to a VPN gateway at home or
at another office. Please adapt the term "office network", which is used throughout this manual, to your scenario.



Task 1 — Configure your D-Link DFL-200

This section describes the configuration of your D-Link DFL-200 router.

TIP  When setting up a VPN, you'll have to handle a couple of parameters. Those parameters are marked with red dots with little
numbers in it. Throughout the setup we will point back to those parameters.



Step 1 - Add a New VPN Tunnel

806

Policy

-
-

Users IPsec Tunnels
[Add new]
—_—
Schedules
L2TP /PPTP Client
Services Name
Add new PPTP client]
[Add new L2TP client]

Port Mapping

T

D-Link

Building Networks for People

D-Link DFL-200 - VPN Tunnels

m Firewall

DFL-200

Network Security Firewall

Servers  Tools

Status Help

VFN Tunnels

VPN tunnel vpntracker deleted

<
=
=z

Certificates

‘Confent Fillering

[

L2TP / PPTP Server
Name

[Add new PPTP server]
[Add new L2TP server]

Picka VPN wnnel to edit from the below list:

LocalNet Remote Net

Type Remote Gateway

o

Help

Remote Gateway

User IPsec

Type  Outer IP Inner IP IPsec

]

» Connect to your DFL-200 and open the Firewall settings.
» Select the VPN settings

» Click “Add new”to create a new VPN tunnel
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Step 2 - Configure your VPN Tunnel

866

D-Link DFL-200

Port Mapping

Users

Schedules

JEEHA ¢

Cerlificates

Content Filtering

[

Changes:

D-Link DFL-200 - VPN Tunnels

Building Networks for People

Network Security Firewall

m GGG Servers  Tools  Stalus

Help

VPN Tunnels

Add IPsec tunnel

Name: wpntracker

Local Net: | 182.168.13.0/24 (1)

Authentication:

®) PSK - Pre-Shared Key
psk @)

Retype PSK:  sssseses

) Certificate-based

Local identity:  Admin - CN=00179AA988F7

Certificates:

Use ctri/shift click to select multiple certificates.
To use ID lists below, you must select a CA certificate

Identity List.  (no list)

—————————————
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» Go to the “Firewall” tab of the firewall's setup interface
and select “VPN”

» Name: Enter a unique name for your VPN tunnel

» Local Net: Enter the IP address of your office network

(1)

» PSK - Pre-Shared Key: Enter your desired password
(pre-share key) (e.g. secretkey) @

» Scroll down for further options (instructions continue
on next page)



D-Link DFL-200 - VPN Tunnels

Tunnel type:

® Roaming Users - single-host IPsec clients

IKE XAuth: E] Require user authentication via IKE XAuth to open tunnel.

) LAN-to-LAN tunnel

Remote Net:
Remote Gateway:

The gateway can be a numerical IP address, DNS
name, or range of IP addresses for roaming /
MATed gateways.
Route: f Automatically add a route for the remote network.
Proxy ARP:  Publish remote network on all interfaces via Proxy ARP.

IKE XAuth client — Pass username a.nd p.assword to peer via IKE XAuth, if the
remote gateway requires it.

XAuth Username:

XAuth Password:

" Delete this VPN tunnel

® 9 0O

Advanced Apply Cancel Help

.sqrt
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» Tunnel type: Select Roaming Users
and check the IKE XAuth checkbox.

» Click Apply



Step 3 - Activate the VPN Tunnel

ea: s et -| » Select Activate from the left menu
| . . .
; ' LT LR DFL-200 | » Click Activate Changes to restart your device and store your
Network Security Firewall } setting S
|
|
‘,—.——4 SGETME Firewall  Servers  Tools  Status Help }
i Activate Changes :
Frrres? “Activate Changes” below to save your changes and have them take :
effect
Ifan administrator does not log in within a settime, the unitwill assume that :
you accidentally locked yourself out, and revert to its previous configuration. |
Waitfor admin login for: | 1 minute -:]belorerevemng. :
1
1
= ;
|
Time :
U
Changes:

= s
s
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Step 4 - Add a New VPN User

B “1 » Select Users from the left menu

[ system PGB Servers  Tools  Siatus  Help » Click Add new, to add a new user to the local authentication

= .
User Management data base
- 1 Enable User Authentication via HTTP / HTTPS

HTTP Security: = HTTP as well as HTTPS

| —— HTTPS only
Port Mapping
Idle Timeout: 2 hours :

Authentication source:

@ Local database

 RADIUS server

Primary Server: port 1812

Secondary Server: port 1812

- N :
Shared Secrat:
" .
Cerlificates Retype Secret:

RADIUS retry: 2 seconds

L Note: Administration of this unit can only be made by administrative
' users in the local database

9 9O

Changes: Apply Cancel Help
Selecta user to editfrom the below list, or select "Add new™:

Administrative user
Discard Change Adminisirator Password

i

LS
Users in local database
- ! Groups  Client IP
v
/|
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D-Link DFL-200 - User Management

) |
|
T DFL-200 .
Network Security Firewall }
|
I
‘;_,:-_s_ m Firewall BEVEH Tools Status Help |
- |
User Management |
- e I
— |
Username:  vpntracker o |
P |
Group membership: |
— |
E R 0 |
r |
Relype password:  sessenes |
|
I
L2TP/PPTP settings: I
Static client IP: I
If empty, the IP address will be taken from the servers IP pool |
Networks behind - |
user: |
|
@ O 0 I
—
Aovly Cancel Helo |
Select a user to edit from the below list, or select "Add new™: |
' Fiteiing |
Administrative user |
Change Adminisirator Password .L
Changes:
Users in local database
| Activate Username Groups Client P
[Add new]

- v
A

» Enter a unique user name €) and password @)

» Apply your settings
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Step 5 - Activate the User

Administrafion
Interfaces
[E——

Routing

Logging

IEEDS

Changes:

Discard

(

D-Link DFL-200 - Activate Changes

DFL-200

Network Security Firewall

1B Firewall  Servers  Tools Status

Help

Activate Changes

Press "Activate Changes” below to save your changes and have them take
effect

If an administrator does not log in within a set time, the unit will assume that
you accidentally locked yourself out, and revert to its previous configuration.

‘Wait for admin login for: "1 minute \:] before reverting.

Activate Changes |

 —————————————

s

£

» Select Activate

» Click Activate Changes to restart your device and store your
settings
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Task 2 - Configure VPN Tracker

This section describes the configuration of VPN Tracker for your D-Link router.

Step 1 - Create a new Connection

» Click on“New”in the VPN Tracker main window.
[Se &) WPN Tracker =
@ =8
k- Edit Duplicate Delete Export Activity Log
Connection Status

VPN service is not running

™ Smart vPN Stop VPN E
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Step 2 - Connection Settings

8eonon Connection: New York | » Select the vendor (D-Link)

: . » Select your VPN router model (DFL-200)
Connection: New York %

» Make sure to enable “Initiate connection from this
end”

{ Connection | MNetwork Authentication Identifiers DNs

Vendor: = D-Link | "]

i

Model: QEEELUSIRRL

- I" How-To... ‘1

Connection Options: @ Initiate connection from this end
| Connect only when needed
" Disable NAT Traversal

[ Client Provisioning

Protocol: = Mode Config =

@ Click the lock to prevent further changes.

[ Cancel ) (—ax—)

TIP  The pre-defined VPN Tracker connection for the D-Link DFL-200 VPN router is based on the default settings for your D-Link

DFL-200 VPN router. If you or the administrator changed any of the settings while configuring the device, you might have
to adjust the connection type in VPN Tracker by double-clicking the model.
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Step 3 - Network Settings

(@60 Connection: New York » VPN Server Address: public IP address of your VPN
— Gateway (e.g. 169.154.19.12)
Connection: New York %
» Remote Network/Mask: network address and

netmask of your office network @

—! Connection | Network | Authentication Identifiers DN5

Topology:  Host to Network | :1

Network Port: ~ Automatic 4]

VPN Gateway Address: 169.154.19.12

Local Address: optional

@ Remote Network/Mask: 192.168.13.0 [ 255.255.255.0 |+

@. Click the lock to prevent further changes.

( cancel ) oK)
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Step 4 - Authentication Settings

m6en Connection: New York
® Pre-shared key: (g
N | @
gHide typing
—@ ) Enter key when establishing connection E—
The key will not be saved on disk.
1

C Cancel )( oK )

@able Extended Authentication (XAUTH)

@ Click the lock to prevent further changes.

Cancel oK

» Pre-shared key: Enter the pre-shared key you used
earlier when configuring the D-Link DFL-200 @

» Make sure to check “Enable Extended
Authentication (XAUTH)”
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Step 5 - Identifiers Settings

eno

Co

nnection: New York

Connection:

New York

@

—! Connection Network

Authentication | Identifiers | DNS

Local Identifier:

Remote Identifier:

&) Local endpoint IP address
() Own certificate

~ )
o c
f¥) Remote endpoint IP address
) Remote certificate

iy m
L ¥

| Verify remote identifier

@ Click the lock to prevent further changes.

C Cancel ) G—H

» Please use the local / remote endpoint IP addresses
as identifiers
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Task 3 - Check the VPN connection

This section explains how to start and test your VPN connection.

It's time to go out!

You will not be able to test and use your VPN connection from within your office network. In order to test your connection, you'll

need to connect from a different location. That's why it's now time to go out. Take your MacBook Pro and have a coffee at your
favorite Internet cafe or go visit a friend.

Test your connection
To test if everything is setup correctly please follow the steps below:
» Get access to the Internet

» Make sure the Internet connection is working; open your Internet browser and try to connect to
http://www.equinux.com

» Start VPN Tracker if it's not already running

22
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e0e VPN Tracker — * Select the connection you configured for your D-

N - Link device
A . o il .
New | Edit Duplicate Delete Export Activity Log » Hit the Start VPN button

Connection Status

M % Mew York

VPN service is not running

P
Authenticate » Provide the username €) and password O defined
Please authenticate to establish the earlier
VPN connection "New York". » Click OK

User Name: vpntracker 9

User Password: sssssas o

gﬂemember this password (add to Keychain)

[ Don't show this dialog again

e ) o)
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ene VPN Tracker =
N = = . = -

A D> e & o Gl
New Edit Duplicate Delete Export Activity Log

Connection

.. New York

Status

Connection to 192.168.13.0/255.255.255.0 7s F)
established.

VPN service is running

# Smart VPN

( Stop VPN ) (- Restart VPN
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» If the light turns red after a few seconds, then
please read the Troubleshooting section on the
next page

» If the light turns green, that means you've
successfully established a connection

Congratulations! You did it!



Troubleshooting

| don’t get a green light in the VPN Tracker main window
» Make sure that your computer is not connected directly to the office network you want to connect to.

» Make sure, that the Identifier and the Pre-shared key you've entered in the router configuration match the settings you entered in
VPN Tracker.

» Verify that the public IP address you entered in VPN Tracker matches the public IP address of your router.

» Download our sample configuration and connect to our test device at http://www.vpntracker.com/connectiontest/

* If the test connection cannot be established: Make sure, that the internet connection is working and verify that your local
router is not blocking any connection attempts.

* If the test connection is established successfully: Your internet connection is working and does not block VPN connections.
Please check the log file of your D-Link DFL-200 for error messages.

» If you're still having issues with your connection, please create some screenshots of your settings on both ends, gather the log files
and send them over to our support team via http://www.equinux.com/us/products/vpntracker/contactus.html.
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What's next?

This section explains how to use your VPN connection.

Introduction

As the VPN connection has now been established, you should be able to access most of the resources in your office network.

Known Limitations

There are some limitations of a VPN connection compared to a direct connection to a office network.
» Bonjour: As Bonjour Chat is not supported over a VPN tunnel, you'll need to use iChat server in order to chat remotely.

» Browsing the network: You can't “browse” the remote network as you're normally used to. You need to connect to each machine
manually, as described on the next page.
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Accessing Files

To access files in your office network, just follow the steps below:

.'. Finder

File Edit

View BN Window Help

Back #[
Forward 3]
Enclosing Folder £

= Computer 2 3C

4 Home {r38H
 Network {r 38K
@ iDisk 3

A Applications {+ A
[ utilities
Recent Folders

Go to Folder...

Connect to 5erver.. [

» Go to the Finder application

» In the menu bar, click on Go->Connect To Server...
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een Connect to Server » Enter the IP address of the machine you want to connect to.

Server Address: In our example network this would be the IP address
192.168.13.21 [+ §O 192.168.13.21
Faverite Servers: » Click on the Connect button

» Enter your Username and Password to access the files

Remaove (" Browse -,I f Connect }
)

TIP  When connecting to a Windows fileserver, you'll need to prefix the IP address with “smb://; e.g. “smb://192.168.13.21"
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Accessing a FileMaker Database

To access a database available in your office network, just follow the steps below:

» Start the FileMaker application

@ FileMaker Pro B8 Edit View Insert Format » In the menu bar, click on File->Open Remote...

New Database...
Open...

Open Remote...
Open Recent
Close

Define

File Options...
Change Password..

Page Setup..

Print..

mport Records
Export Records...
Save/Send Records As
Send Mail...

Save a Copy As..
Recover...
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Open Remote File _» Click on the Add... button

View: | Favorite Hosts l—ii
Hosts Available Files
( Add... e Edit... Remaove
Network File Path: |
Example - fmnet:/hostIPAddress /fileName
P
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Edit Favorite Host

Favorite Settings

Host's Internet Address: 192.168.13.22
(Example - host.domain.com or 192.168.10.0)

Favorite Host's Name: Remote FM Server

(optional)
File Settings

®) Show all available files for this host

(") Show only these files

FMServer_Sample

) I »

Enter one file name per line, separated by a carriage return

(Cancelj f Save )
A

» Enter the IP address of the FileMaker server machine
» Enter a hostname for this machine (optional)

» Click on the Save button
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Open Remote File

View: | Favorite Hosts ']

Hosts Available Files

Remote FM Server (152.168.13.22)

P

( Add.. )( Edit.. )( Remove )

Network File Path: fmnet:/192.168.13.22/
Example - fmnet: /hostIPAddress /fileName

1 )
| Cancel )

Open

Z)

» Select a database from the list of Available Files and click
Open

» You are now able to access your FileMaker databases as
usual
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Acquire more Licenses

If two or more people need to access your office network via VPN, then you need to acquire more VPN
Tracker licenses.

To get more licenses, please contact your reseller and inquire about,VPN Tracker Personal Edition”.

Or point your browser to http://store.equinux.com and buy additional VPN Tracker Personal Edition Licenses online.
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